Read the docs
TI-2024-29520 Aliases CVE-2024-43931GHSA-3gcf-28pg-3vm2

WordPress JobSearch WP Job Board WordPress Plugin plugin <= 2.5.3 - PHP Object Injection vulnerability

Priority MEDIUM 49CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.

Summary

Deserialization of Untrusted Data vulnerability in eyecix JobSearch allows Object Injection.This issue affects JobSearch: from n/a through 2.5.3.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00523 44th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
eyecixJobSearchup to 2.5.3—No fix listedCNA
  • JobSearch Vendoreyecix Affected up to 2.5.3 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:eyecix:jobsearch_wp_job_board:*:*:*:*:*:wordpress:*:*before 2.5.4Vulnerableeyecix
  • cpe:2.3:a:eyecix:jobsearch_wp_job_board:*:*:*:*:*:wordpress:*:* Versions before 2.5.4 Vulnerable ·eyecix

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-43931
  2. 2026-10-03 Alias added: GHSA-3gcf-28pg-3vm2

References

  • TI-2023-06036 JobSearch WP Job Board < 2.3.4 - Arbitrary File Upload to RCE CVSS 3.1HIGH 7.5
  • TI-2024-07991 WP JobSearch <= 2.6.7 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 10.0
  • TI-2024-07990 WP JobSearch <= 2.6.7 - Authenticated (Subscriber+) Arbitrary File Upload CVSS 3.1CRITICAL 9.9
  • TI-2024-29518 WordPress JobSearch WP Job Board WordPress Plugin plugin <= 2.5.4 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2024-31915 WordPress WP JobSearch plugin <= 2.5.9 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2021-03218 JobSearch WP Job Board <= 1.8.1 - Missing Authorization to Arbitrary Options Update CVSS 3.1HIGH 8.8
See all 12 →

Sources