WP JobSearch <= 2.6.7 - Authenticated (Subscriber+) Arbitrary File Upload
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.
Summary
The JobSearch WP Job Board plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the jobsearch_wp_handle_upload() function in all versions up to, and including, 2.6.7. This makes it possible for authenticated attackers, with subscriber-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8614
- 2026-10-03 Alias added: GHSA-xcrw-r9q7-wxcx
References
More eyecix Jobsearch Wp Job Board vulnerabilities
- TI-2023-06036 JobSearch WP Job Board < 2.3.4 - Arbitrary File Upload to RCE CVSS 3.1HIGH 7.5
- TI-2024-07991 WP JobSearch <= 2.6.7 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 10.0
- TI-2024-29520 WordPress JobSearch WP Job Board WordPress Plugin plugin <= 2.5.3 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-29518 WordPress JobSearch WP Job Board WordPress Plugin plugin <= 2.5.4 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-31915 WordPress WP JobSearch plugin <= 2.5.9 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2021-03218 JobSearch WP Job Board <= 1.8.1 - Missing Authorization to Arbitrary Options Update CVSS 3.1HIGH 8.8
Sources
- CVE-2024-8614 · CVE Program
- CVE-2024-8614 · NVD
- FIRST EPSS
- GHSA-xcrw-r9q7-wxcx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences