Read the docs
TI-2023-06369 Aliases CVE-2023-6967GHSA-33g4-2m49-x49h

Pods - Custom Content Types and Fields - Authenticated (Contributor+) SQL Injection via Shortcode

Priority MEDIUM 42CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.

Summary

The Pods – Custom Content Types and Fields plugin for WordPress is vulnerable to SQL Injection via shortcode in all versions up to, and including, 3.0.10 (with the exception of 2.7.31.2, 2.8.23.2, 2.9.19.2) due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor level access or higher, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00821 57th percentileScored 2026-11-07
Fix Fixed Pods – Custom Content Types and Fields (sc0ttkclark): 2.7.31, 2.8.23.2, 3.0.10.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
sc0ttkclarkPods – Custom Content Types and Fieldsbefore 2.7.31; 2.8 to before 2.8.23.2; 3 to before 3.0.10.22.7.31, 2.8.23.2, 3.0.10.2Patch availableCNA
  • Pods – Custom Content Types and Fields Vendorsc0ttkclark Affected before 2.7.31; 2.8 to before 2.8.23.2; 3 to before 3.0.10.2 Fixed in 2.7.31, 2.8.23.2, 3.0.10.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:podsfoundation:pods:*:*:*:*:*:wordpress:*:*before 2.7.31.2; 2.8 to before 2.8.23.2; 2.9 to before 2.9.19.2; 3.0.0 to before 3.0.10.2Vulnerablesc0ttkclark
  • cpe:2.3:a:podsfoundation:pods:*:*:*:*:*:wordpress:*:* Versions before 2.7.31.2; 2.8 to before 2.8.23.2; 2.9 to before 2.9.19.2; 3.0.0 to before 3.0.10.2 Vulnerable ·sc0ttkclark

Remediation

  • Fix · CNA Pods – Custom Content Types and Fields (sc0ttkclark) Fixed in 2.7.31, 2.8.23.2, 3.0.10.2

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    sc0ttkclark Pods – Custom Content Types and Fields 2.7.31, 2.8.23.2, 3.0.10.2

    3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2023-06398 Pods - Custom Content Types and Fields - Authenticated (Contributor+) Remote Code ExecutionPriority MEDIUM 43
    • TI-2023-06367 Pods - Custom Content Types and Fields - Missing AuthorizationPriority LOW 21

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-6967
  2. 2026-10-03 Alias added: GHSA-33g4-2m49-x49h

References

  • TI-2025-01242 Pods < 3.2.8.2 - Admin+ SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2024-10992 Pods – Custom Content Types and Fields < 3.2.8.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 6.1
  • TI-2024-09169 Pods < 3.2.7.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2023-06398 Pods - Custom Content Types and Fields - Authenticated (Contributor+) Remote Code Execution CVSS 3.1HIGH 8.8
  • TI-2023-09590 WordPress Pods Plugin <= 2.9.10.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2021-06631 Pods < 2.7.27 - Authenticated Stored Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 5.4
See all 9 →

Sources