Pods – Custom Content Types and Fields < 3.2.8.1 - Admin+ Stored XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Pods WordPress plugin before 3.2.8.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00326 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Pods (Unknown): 3.2.8.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Pods | before 3.2.8.1 | 3.2.8.1 | Patch available | CNA |
- Pods VendorUnknown Affected before 3.2.8.1 Fixed in 3.2.8.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:podsfoundation:pods:*:*:*:*:*:wordpress:*:* | before 3.2.8.1 | Vulnerable | sc0ttkclark |
- cpe:2.3:a:podsfoundation:pods:*:*:*:*:*:wordpress:*:* Versions before 3.2.8.1 Vulnerable ·sc0ttkclark
Remediation
- Fix · CNA Pods (Unknown) Fixed in 3.2.8.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-11849
- 2026-10-03 Alias added: GHSA-7mxj-3f68-p2v6
References
More sc0ttkclark Pods vulnerabilities
- TI-2025-01242 Pods < 3.2.8.2 - Admin+ SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2024-09169 Pods < 3.2.7.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-06398 Pods - Custom Content Types and Fields - Authenticated (Contributor+) Remote Code Execution CVSS 3.1HIGH 8.8
- TI-2023-06369 Pods - Custom Content Types and Fields - Authenticated (Contributor+) SQL Injection via Shortcode CVSS 3.1HIGH 8.8
- TI-2023-09590 WordPress Pods Plugin <= 2.9.10.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2021-06631 Pods < 2.7.27 - Authenticated Stored Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-11849 · CVE Program
- CVE-2024-11849 · NVD
- FIRST EPSS
- GHSA-7mxj-3f68-p2v6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences