Read the docs
TI-2023-06509 Aliases CVE-2023-7115GHSA-768f-hg28-693m

PageLayer < 1.8.1 - Admin+ Stored XSS

Priority LOW 22CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Page Builder: Pagelayer WordPress plugin before 1.8.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00402 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Page Builder: Pagelayer (Unknown): 1.8.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPage Builder: Pagelayerbefore 1.8.11.8.1Patch availableCNA
  • Page Builder: Pagelayer VendorUnknown Affected before 1.8.1 Fixed in 1.8.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pagelayer:pagelayer:*:*:*:*:*:wordpress:*:*before 1.8.1VulnerablePagelayer
  • cpe:2.3:a:pagelayer:pagelayer:*:*:*:*:*:wordpress:*:* Versions before 1.8.1 Vulnerable ·Pagelayer

Remediation

  • Fix · CNA Page Builder: Pagelayer (Unknown) Fixed in 1.8.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-7115
  2. 2026-10-03 Alias added: GHSA-768f-hg28-693m

References

  • TI-2023-04319 PageLayer < 1.7.7 - Unauthenticated Stored XSS CVSS 3.1MEDIUM 6.1
  • TI-2023-04681 PageLayer < 1.7.8 - Author+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2024-07994 Page Builder: Pagelayer < 1.9.0- Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-07811 Pagelayer < 1.8.8 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2023-04713 PageLayer < 1.8.0 - Author+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2020-18385 An issue was discovered in the PageLayer plugin before 1.1.2 for WordPress. CVSS 3.1HIGH 8.8
See all 18 →

Sources