Metabase subject to Exposure of Sensitive Information to an Unauthorized Actor
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-200.
Summary
Metabase is an open source data analytics platform. Affected versions are subject to Exposure of Sensitive Information to an Unauthorized Actor. Sandboxed users shouldn't be able to view data about other Metabase users anywhere in the Metabase application. However, when a sandbox user views the settings for a dashboard subscription, and another user has added users to that subscription, the sandboxed user is able to view the list of recipients for that subscription. This issue is patched in versions 0.43.7.1, 1.43.7.1, 0.44.6.1, 1.44.6.1, 0.45.2.1, and 1.45.2.1. There are no workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Metabase | metabase | before 0.43.7.1; 0.44.0-RC1 to before 0.44.6.1; 0.45.0-RC1 to before 0.45.2.1; 1.0.0 to before 1.43.7.1; 1.44.0-RC1 to before 1.44.6.1; 1.45.0-RC1 to before 1.45.2.1 | 0.43.7.1, 0.44.6.1, 0.45.2.1, 1.43.7.1, 1.44.6.1, 1.45.2.1 | Patch available | CNA |
- metabase VendorMetabase Affected before 0.43.7.1; 0.44.0-RC1 to before 0.44.6.1; 0.45.0-RC1 to before 0.45.2.1; 1.0.0 to before 1.43.7.1; 1.44.0-RC1 to before 1.44.6.1; 1.45.0-RC1 to before 1.45.2.1 Fixed in 0.43.7.1, 0.44.6.1, 0.45.2.1, 1.43.7.1, 1.44.6.1, 1.45.2.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metabase:metabase:*:*:*:*:*:*:*:* | before 0.43.7.1; 0.44.0 to before 0.44.6.1; 0.45.0 to before 0.45.2.1; 1.0.0 to before 1.43.7.1; 1.44.0 to before 1.44.6.1; 1.45.0 to before 1.45.2.1 | Vulnerable | Metabase |
- cpe:2.3:a:metabase:metabase:*:*:*:*:*:*:*:* Versions before 0.43.7.1; 0.44.0 to before 0.44.6.1; 0.45.0 to before 0.45.2.1; 1.0.0 to before 1.43.7.1; 1.44.0 to before 1.44.6.1; 1.45.0 to before 1.45.2.1 Vulnerable ·Metabase
Remediation
- Fix · CNA metabase (metabase) Fixed in 0.43.7.1, 0.44.6.1, 0.45.2.1, 1.43.7.1, 1.44.6.1, 1.45.2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-23628
References
More Metabase vulnerabilities
- TI-2026-51115 Metabase SQL injection via password reset endpoint KEVCVSS 4.0CRITICAL 10.0
- TI-2021-18109 GeoJSON URL validation can expose server files and environment variables to unauthorized users KEVCVSS 3.1CRITICAL 10.0
- TI-2023-20003 Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow… CVSS 3.1CRITICAL 9.8
- TI-2022-08664 File system exposure in Metabase CVSS 3.1MEDIUM 5.9
- TI-2025-05321 Metabase dom.js parseDataUri redos CVSS 4.0MEDIUM 5.3
- TI-2023-19078 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint CVSS 3.1CRITICAL 10.0
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences