Read the docs
TI-2023-09564 Aliases CVE-2023-23761GHSA-q7wq-398w-6957

Improper authentication vulnerability in GitHub Enterprise Server leading to modification of secret gists

Priority LOW 36CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-287.

Summary

An improper authentication vulnerability was identified in GitHub Enterprise Server that allowed an unauthorized actor to modify other users' secret gists by authenticating through an SSH certificate authority. To do so, a user had to know the secret gist's URL. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.9 and was fixed in versions 3.4.18, 3.5.15, 3.6.11, 3.7.8, and 3.8.1. This vulnerability was reported via the GitHub Bug Bounty program.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00462 40th percentileScored 2026-11-07
Fix Fixed Enterprise Server (GitHub): 3.8.1, 3.9.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
GitHubEnterprise Server3.4.0 – 3.4.17; 3.5.0 – 3.5.14; 3.6.0 – 3.6.10; 3.7.0 – 3.7.7; 3.8.0 to before 3.8.13.8.1, 3.9.0Patch availableCNA
  • Enterprise Server VendorGitHub Affected 3.4.0 – 3.4.17; 3.5.0 – 3.5.14; 3.6.0 – 3.6.10; 3.7.0 – 3.7.7; 3.8.0 to before 3.8.1 Fixed in 3.8.1, 3.9.0 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*before 3.4.18; 3.5.0 to before 3.5.15; 3.6.0 to before 3.6.11; 3.7.0 to before 3.7.8VulnerableGitHub
cpe:2.3:a:github:enterprise_server:3.8.0:*:*:*:*:*:*:*3.8.0VulnerableGitHub
  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* Versions before 3.4.18; 3.5.0 to before 3.5.15; 3.6.0 to before 3.6.11; 3.7.0 to before 3.7.8 Vulnerable ·GitHub
  • cpe:2.3:a:github:enterprise_server:3.8.0:*:*:*:*:*:*:* Versions 3.8.0 Vulnerable ·GitHub

Remediation

  • Fix · CNA Enterprise Server (GitHub) Fixed in 3.8.1, 3.9.0

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    GitHub Enterprise Server 3.8.1

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2023-09565 Incorrect comparison vulnerability in GitHub Enterprise Server leading to commit smugglingPriority LOW 30

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-23761
  2. 2026-10-03 Alias added: GHSA-q7wq-398w-6957

References

  • TI-2024-04632 An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)… CVSS 4.0CRITICAL 10.0
  • TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
  • TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
  • TI-2026-03340 Remote code execution via git push option injection in GitHub Enterprise Server CVSS 4.0HIGH 8.7
  • TI-2024-08804 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
  • TI-2026-08177 Server-side request forgery in GitHub Enterprise Server CVSS 4.0CRITICAL 9.2
See all 125 →

Sources