Incorrect comparison vulnerability in GitHub Enterprise Server leading to commit smuggling
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
An incorrect comparison vulnerability was identified in GitHub Enterprise Server that allowed commit smuggling by displaying an incorrect diff. To do so, an attacker would need write access to the repository and be able to correctly guess the target branch before it’s created by the code maintainer. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.9 and was fixed in versions 3.4.18, 3.5.15, 3.6.11, 3.7.8, and 3.8.1. This vulnerability was reported via the GitHub Bug Bounty program.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitHub | Enterprise Server | 3.4.0 – 3.4.17; 3.5.0 – 3.5.14; 3.6.0 – 3.6.10; 3.7.0 – 3.7.7; 3.8.0 to before 3.8.1 | 3.8.1, 3.9.0 | Patch available | CNA |
- Enterprise Server VendorGitHub Affected 3.4.0 – 3.4.17; 3.5.0 – 3.5.14; 3.6.0 – 3.6.10; 3.7.0 – 3.7.7; 3.8.0 to before 3.8.1 Fixed in 3.8.1, 3.9.0 Patch available CNA
Remediation
- Fix · CNA Enterprise Server (GitHub) Fixed in 3.8.1, 3.9.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitHub Enterprise Server 3.8.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2023-09564 Improper authentication vulnerability in GitHub Enterprise Server leading to modification of secret gistsPriority LOW 36
Timeline
- 2026-10-02 Threatist record created from CVE-2023-23762
- 2026-10-03 Alias added: GHSA-jv37-6f69-j8gw
- 2026-10-23 EPSS moved to the 50th–90th percentile
References
Other 5
- https://docs.github.com/en/[email protected]/admin/release-notes#3.8.1
- https://docs.github.com/en/[email protected]/admin/release-notes#3.7.8
- https://docs.github.com/en/[email protected]/admin/release-notes#3.6.11
- https://docs.github.com/en/[email protected]/admin/release-notes#3.5.15
- https://docs.github.com/en/[email protected]/admin/release-notes#3.4.18
More GitHub Enterprise Server vulnerabilities
- TI-2024-04632 An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)… CVSS 4.0CRITICAL 10.0
- TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
- TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
- TI-2026-03340 Remote code execution via git push option injection in GitHub Enterprise Server CVSS 4.0HIGH 8.7
- TI-2024-08804 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
- TI-2026-08177 Server-side request forgery in GitHub Enterprise Server CVSS 4.0CRITICAL 9.2
Sources
- CVE-2023-23762 · CVE Program
- CVE-2023-23762 · NVD
- FIRST EPSS
- GHSA-jv37-6f69-j8gw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences