Read the docs
TI-2023-10809 Aliases CVE-2023-25504GHSA-fxjg-28fm-pfxh

Apache Superset: Possible SSRF on import datasets

Priority LOW 31CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.

Summary

A malicious actor who has been authenticated and granted specific permissions in Apache Superset may use the import dataset feature in order to conduct Server-Side Request Forgery attacks and query internal resources on behalf of the server where Superset is deployed. This vulnerability exists in Apache Superset versions up to and including 2.0.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00957 61st percentileScored 2026-11-07
Fix Fixed apache-superset (PyPI): 2.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Supersetup to 2.0.1—No fix listedCNA
—apache-superset (PyPI)before 2.1.02.1.0Patch availableGHSA-fxjg-28fm-pfxh
  • Apache Superset VendorApache Affected up to 2.0.1 Fixed in — No fix listed CNA
  • apache-superset (PyPI) Vendor— Affected before 2.1.0 Fixed in 2.1.0 Patch available GHSA-fxjg-28fm-pfxh

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:*up to 2.0.1VulnerableApache
  • cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:* Versions up to 2.0.1 Vulnerable ·Apache

Remediation

  • Fix · GHSA-fxjg-28fm-pfxh apache-superset (PyPI) Fixed in 2.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-25504
  2. 2026-10-03 Alias added: GHSA-fxjg-28fm-pfxh

References

  • TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
  • TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
  • TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
  • TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
  • TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
See all 69 →

Sources