Read the docs
TI-2023-10866 Aliases CVE-2023-25563

GSS-NTLMSSP vulnerable to multiple out-of-bounds reads when decoding NTLM fields

Priority LOW 35CWE-125Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-125 and the CVSS impact.

Summary

GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, multiple out-of-bounds reads when decoding NTLM fields can trigger a denial of service. A 32-bit integer overflow condition can lead to incorrect checks of consistency of length of internal buffers. Although most applications will error out before accepting a singe input buffer of 4GB in length this could theoretically happen. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point if the application allows tokens greater than 4GB in length. This can lead to a large, up to 65KB, out-of-bounds read which could cause a denial-of-service if it reads from unmapped memory. Version 1.2.0 contains a patch for the out-of-bounds reads.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01091 65th percentileScored 2026-11-07
Fix Fixed gss-ntlmssp (gssapi): 1.2.0Red Hat: 1 advisory

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
gssapigss-ntlmsspbefore 1.2.01.2.0Patch availableCNA
  • gss-ntlmssp Vendorgssapi Affected before 1.2.0 Fixed in 1.2.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:gss-ntlmssp_project:gss-ntlmssp:*:*:*:*:*:*:*:*before 1.2.0Vulnerablegssapi
  • cpe:2.3:a:gss-ntlmssp_project:gss-ntlmssp:*:*:*:*:*:*:*:* Versions before 1.2.0 Vulnerable ·gssapi

Remediation

  • Fix · CNA gss-ntlmssp (gssapi) Fixed in 1.2.0

Red Hat 1 advisory

  • RHSA-2023:3097 Released 2023-05-16 · Red Hat rating Moderate
    gssntlmssp security update
    • Red Hat Enterprise Linux AppStream (v. 8) gssntlmssp-1.2.0-1.el8_8

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2023:3097

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-25563

References

  • TI-2023-10870 GSS-NTLMSSP vulnerable to out-of-bounds read when decoding target information CVSS 3.1HIGH 7.5
  • TI-2023-10869 GSS-NTLMSSP vulnerable to memory leak when parsing usernames CVSS 3.1HIGH 7.5
  • TI-2023-10868 GSS-NTLMSSP vulnerable to incorrect free when decoding target information CVSS 3.1HIGH 7.5
  • TI-2023-10867 GSS-NTLMSSP vulnerable to memory corruption when decoding UTF16 strings CVSS 3.1HIGH 8.2

Sources