GSS-NTLMSSP vulnerable to incorrect free when decoding target information
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, an incorrect free when decoding target information can trigger a denial of service. The error condition incorrectly assumes the `cb` and `sh` buffers contain a copy of the data that needs to be freed. However, that is not the case. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This will likely trigger an assertion failure in `free`, causing a denial-of-service. This issue is fixed in version 1.2.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA gss-ntlmssp (gssapi) Fixed in 1.2.0
Red Hat 1 advisory
- RHSA-2023:3097 Released 2023-05-16 · Red Hat rating Moderategssntlmssp security update
- Red Hat Enterprise Linux AppStream (v. 8) gssntlmssp-1.2.0-1.el8_8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2023:3097 |
Timeline
- 2026-10-02 Threatist record created from CVE-2023-25565
References
More gssapi Gss-ntlmssp vulnerabilities
- TI-2023-10870 GSS-NTLMSSP vulnerable to out-of-bounds read when decoding target information CVSS 3.1HIGH 7.5
- TI-2023-10869 GSS-NTLMSSP vulnerable to memory leak when parsing usernames CVSS 3.1HIGH 7.5
- TI-2023-10867 GSS-NTLMSSP vulnerable to memory corruption when decoding UTF16 strings CVSS 3.1HIGH 8.2
- TI-2023-10866 GSS-NTLMSSP vulnerable to multiple out-of-bounds reads when decoding NTLM fields CVSS 3.1HIGH 7.5
Sources
- CVE-2023-25565 · CVE Program
- CVE-2023-25565 · NVD
- FIRST EPSS
- CVE-2023-25565 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences