GSS-NTLMSSP vulnerable to out-of-bounds read when decoding target information
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-125 and the CVSS impact.
Summary
GSS-NTLMSSP, a mechglue plugin for the GSSAPI library that implements NTLM authentication, has an out-of-bounds read when decoding target information prior to version 1.2.0. The length of the `av_pair` is not checked properly for two of the elements which can trigger an out-of-bound read. The out-of-bounds read can be triggered via the main `gss_accept_sec_context` entry point and could cause a denial-of-service if the memory is unmapped. The issue is fixed in version 1.2.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA gss-ntlmssp (gssapi) Fixed in 1.2.0
Red Hat 1 advisory
- RHSA-2023:3097 Released 2023-05-16 · Red Hat rating Moderategssntlmssp security update
- Red Hat Enterprise Linux AppStream (v. 8) gssntlmssp-1.2.0-1.el8_8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2023:3097 |
Timeline
- 2026-10-02 Threatist record created from CVE-2023-25567
References
More gssapi Gss-ntlmssp vulnerabilities
- TI-2023-10869 GSS-NTLMSSP vulnerable to memory leak when parsing usernames CVSS 3.1HIGH 7.5
- TI-2023-10868 GSS-NTLMSSP vulnerable to incorrect free when decoding target information CVSS 3.1HIGH 7.5
- TI-2023-10867 GSS-NTLMSSP vulnerable to memory corruption when decoding UTF16 strings CVSS 3.1HIGH 8.2
- TI-2023-10866 GSS-NTLMSSP vulnerable to multiple out-of-bounds reads when decoding NTLM fields CVSS 3.1HIGH 7.5
Sources
- CVE-2023-25567 · CVE Program
- CVE-2023-25567 · NVD
- FIRST EPSS
- CVE-2023-25567 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences