Read the docs
TI-2023-19373 Aliases CVE-2023-37941GHSA-fj4x-m62j-wvwg

Apache Superset: Metadata db write access can lead to remote code execution

Priority MEDIUM 57CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
High
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend. The Superset metadata db is an 'internal' component that is typically only accessible directly by the system administrator and the superset process itself. Gaining access to that database should be difficult and require significant privileges. This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.35455 98th percentileScored 2026-11-07
Fix Fixed apache-superset (PyPI): 2.1.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Superset1.5.0 – 2.1.0—No fix listedCNA
—apache-superset (PyPI)1.5.0 to before 2.1.12.1.1Patch availableGHSA-fj4x-m62j-wvwg
  • Apache Superset VendorApache Affected 1.5.0 – 2.1.0 Fixed in — No fix listed CNA
  • apache-superset (PyPI) Vendor— Affected 1.5.0 to before 2.1.1 Fixed in 2.1.1 Patch available GHSA-fj4x-m62j-wvwg

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:*1.5.0 – 2.1.0VulnerableApache
  • cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:* Versions 1.5.0 – 2.1.0 Vulnerable ·Apache

Remediation

  • Fix · GHSA-fj4x-m62j-wvwg apache-superset (PyPI) Fixed in 2.1.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-37941
  2. 2026-10-03 Alias added: GHSA-fj4x-m62j-wvwg

References

  • TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
  • TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
  • TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
  • TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
  • TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
See all 69 →

Sources