Read the docs
TI-2023-14617 Aliases CVE-2023-30837GHSA-mgv8-gggw-mrg6

Vyper storage allocator overflow

Priority MEDIUM 40CWE-789Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-789.

Summary

Vyper is a pythonic smart contract language for the EVM. The storage allocator does not guard against allocation overflows in versions prior to 0.3.8. An attacker can overwrite the owner variable. This issue was fixed in version 0.3.8.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00697 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed vyper (vyperlang): 0.3.8vyper (PyPI): 0.3.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vyperlangvyperbefore 0.3.80.3.8Patch availableCNA
—vyper (PyPI)before 0.3.80.3.8Patch availableGHSA-mgv8-gggw-mrg6
  • vyper Vendorvyperlang Affected before 0.3.8 Fixed in 0.3.8 Patch available CNA
  • vyper (PyPI) Vendor— Affected before 0.3.8 Fixed in 0.3.8 Patch available GHSA-mgv8-gggw-mrg6

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vyperlang:vyper:*:*:*:*:*:*:*:*before 0.3.8Vulnerablevyperlang
  • cpe:2.3:a:vyperlang:vyper:*:*:*:*:*:*:*:* Versions before 0.3.8 Vulnerable ·vyperlang

Remediation

  • Fix · CNA vyper (vyperlang) Fixed in 0.3.8
  • Fix · GHSA-mgv8-gggw-mrg6 vyper (PyPI) Fixed in 0.3.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-30837
  2. 2026-10-03 Alias added: GHSA-mgv8-gggw-mrg6

References

  • TI-2024-16182 Vyper bounds check on built-in `slice()` function can be overflowed CVSS 3.1CRITICAL 9.8
  • TI-2024-14992 concat built-in can corrupt memory in vyper CVSS 3.1CRITICAL 9.8
  • TI-2024-16184 Vyper array negative index vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2022-08657 Integer bounds error in Vyper CVSS 3.1CRITICAL 9.8
  • TI-2022-11796 Multiple evaluation of contract address in call in vyper CVSS 3.1HIGH 8.2
  • TI-2024-21531 vyper performs double eval of the argument of sqrt CVSS 3.1MEDIUM 5.3
See all 37 →

Sources