Vyper vulnerable to integer overflow in loop
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-190 and the CVSS impact.
Summary
Vyper is a Pythonic smart contract language for the Ethereum virtual machine. Prior to version 0.3.8, due to missing overflow check for loop variables, by assigning the iterator of a loop to a variable, it is possible to overflow the type of the latter. The issue seems to happen only in loops of type `for i in range(a, a + N)` as in loops of type `for i in range(start, stop)` and `for i in range(stop)`, the compiler is able to raise a `TypeMismatch` when trying to overflow the variable. The problem has been patched in version 0.3.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vyperlang | vyper | before 0.3.8 | 0.3.8 | Patch available | CNA |
| — | vyper (PyPI) | before 0.3.8 | 0.3.8 | Patch available | GHSA-6r8q-pfpv-7cgj |
- vyper Vendorvyperlang Affected before 0.3.8 Fixed in 0.3.8 Patch available CNA
- vyper (PyPI) Vendor— Affected before 0.3.8 Fixed in 0.3.8 Patch available GHSA-6r8q-pfpv-7cgj
Remediation
- Fix · CNA vyper (vyperlang) Fixed in 0.3.8
- Fix · GHSA-6r8q-pfpv-7cgj vyper (PyPI) Fixed in 0.3.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32058
- 2026-10-03 Alias added: GHSA-6r8q-pfpv-7cgj
References
More vyperlang Vyper vulnerabilities
- TI-2024-16182 Vyper bounds check on built-in `slice()` function can be overflowed CVSS 3.1CRITICAL 9.8
- TI-2024-14992 concat built-in can corrupt memory in vyper CVSS 3.1CRITICAL 9.8
- TI-2024-16184 Vyper array negative index vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-08657 Integer bounds error in Vyper CVSS 3.1CRITICAL 9.8
- TI-2022-11796 Multiple evaluation of contract address in call in vyper CVSS 3.1HIGH 8.2
- TI-2024-21531 vyper performs double eval of the argument of sqrt CVSS 3.1MEDIUM 5.3
Sources
- CVE-2023-32058 · CVE Program
- CVE-2023-32058 · NVD
- FIRST EPSS
- GHSA-6r8q-pfpv-7cgj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences