Read the docs
TI-2023-15951 Aliases CVE-2023-32675GHSA-vxmm-cwh2-q762

Nonpayable default functions are sometimes payable in vyper

Priority LOW 25CWE-670Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. In contracts with more than one regular nonpayable function, it is possible to send funds to the default function, even if the default function is marked `nonpayable`. This applies to contracts compiled with vyper versions prior to 0.3.8. This issue was fixed by the removal of the global `calldatasize` check in commit `02339dfda`. Users are advised to upgrade to version 0.3.8. Users unable to upgrade should avoid use of nonpayable default functions.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00553 46th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed vyper (vyperlang): 0.3.8vyper (PyPI): 0.3.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vyperlangvyperbefore 0.3.80.3.8Patch availableCNA
—vyper (PyPI)before 0.3.80.3.8Patch availableGHSA-vxmm-cwh2-q762
  • vyper Vendorvyperlang Affected before 0.3.8 Fixed in 0.3.8 Patch available CNA
  • vyper (PyPI) Vendor— Affected before 0.3.8 Fixed in 0.3.8 Patch available GHSA-vxmm-cwh2-q762

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vyperlang:vyper:*:*:*:*:*:*:*:*before 0.3.8Vulnerablevyperlang
  • cpe:2.3:a:vyperlang:vyper:*:*:*:*:*:*:*:* Versions before 0.3.8 Vulnerable ·vyperlang

Remediation

  • Fix · CNA vyper (vyperlang) Fixed in 0.3.8
  • Fix · GHSA-vxmm-cwh2-q762 vyper (PyPI) Fixed in 0.3.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-32675
  2. 2026-10-03 Alias added: GHSA-vxmm-cwh2-q762

References

  • TI-2024-16182 Vyper bounds check on built-in `slice()` function can be overflowed CVSS 3.1CRITICAL 9.8
  • TI-2024-14992 concat built-in can corrupt memory in vyper CVSS 3.1CRITICAL 9.8
  • TI-2024-16184 Vyper array negative index vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2022-08657 Integer bounds error in Vyper CVSS 3.1CRITICAL 9.8
  • TI-2022-11796 Multiple evaluation of contract address in call in vyper CVSS 3.1HIGH 8.2
  • TI-2024-21531 vyper performs double eval of the argument of sqrt CVSS 3.1MEDIUM 5.3
See all 37 →

Sources