Missing SQL permissions check in metabase
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-306.
Summary
Metabase is an open source business analytics engine. To edit SQL Snippets, Metabase should have required people to be in at least one group with native query editing permissions to a database–but affected versions of Metabase didn't enforce that requirement. This lack of enforcement meant that: Anyone–including people in sandboxed groups–could edit SQL snippets. They could edit snippets via the API or, in the application UI, when editing the metadata for a model based on a SQL question, and people in sandboxed groups could edit a SQL snippet used in a query that creates their sandbox. If the snippet contained logic that restricted which data that person could see, they could potentially edit that snippet and change their level of data access. The permissions model for SQL snippets has been fixed in Metabase versions 0.46.3, 0.45.4, 0.44.7, 1.46.3, 1.45.4, and 1.44.7. Users are advised to upgrade. Users unable to upgrade should ensure that SQL queries used to create sandboxes exclude SQL snippets.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Metabase | metabase | before 0.44.7; 1.0.0 to before 1.44.7; 0.45.0 to before 0.45.4; 1.0.0 to before 1.45.4; 0.46.0 to before 0.46.3; 1.0.0 to before 1.46.3 | 0.44.7, 1.44.7, 0.45.4, 1.45.4, 0.46.3, 1.46.3 | Patch available | CNA |
- metabase VendorMetabase Affected before 0.44.7; 1.0.0 to before 1.44.7; 0.45.0 to before 0.45.4; 1.0.0 to before 1.45.4; 0.46.0 to before 0.46.3; 1.0.0 to before 1.46.3 Fixed in 0.44.7, 1.44.7, 0.45.4, 1.45.4, 0.46.3, 1.46.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metabase:metabase:*:*:*:*:*:*:*:* | before 0.44.7; 0.45.0 to before 0.45.4; 0.46.0 to before 0.46.3; 1.0.0 to before 1.44.7; 1.45.0 to before 1.45.4; 1.46.0 to before 1.46.3 | Vulnerable | Metabase |
- cpe:2.3:a:metabase:metabase:*:*:*:*:*:*:*:* Versions before 0.44.7; 0.45.0 to before 0.45.4; 0.46.0 to before 0.46.3; 1.0.0 to before 1.44.7; 1.45.0 to before 1.45.4; 1.46.0 to before 1.46.3 Vulnerable ·Metabase
Remediation
- Fix · CNA metabase (metabase) Fixed in 0.44.7, 1.44.7, 0.45.4, 1.45.4, 0.46.3, 1.46.3
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32680
References
More Metabase vulnerabilities
- TI-2026-51115 Metabase SQL injection via password reset endpoint KEVCVSS 4.0CRITICAL 10.0
- TI-2021-18109 GeoJSON URL validation can expose server files and environment variables to unauthorized users KEVCVSS 3.1CRITICAL 10.0
- TI-2023-20003 Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow… CVSS 3.1CRITICAL 9.8
- TI-2022-08664 File system exposure in Metabase CVSS 3.1MEDIUM 5.9
- TI-2025-05321 Metabase dom.js parseDataUri redos CVSS 4.0MEDIUM 5.3
- TI-2023-19078 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint CVSS 3.1CRITICAL 10.0
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences