Cross-site scripting in Jenkins Pipeline: Job Plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 3 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Jenkins Pipeline: Job Plugin does not escape the display name of the build that caused an earlier build to be aborted, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to set build display names immediately.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Pipeline: Job Plugin | — | 1295.v395eb_7400005, 1289.1291.vb_7c188e7e7df, 1207.1209.v69351208a_5a_7 | Patch available | CNA |
| — | org.jenkins-ci.plugins.workflow:workflow-job (Maven) | before 1295.v395eb | 1295.v395eb | Patch available | GHSA-2wvv-phhw-qvmc |
- Jenkins Pipeline: Job Plugin VendorJenkins Affected — Fixed in 1295.v395eb_7400005, 1289.1291.vb_7c188e7e7df, 1207.1209.v69351208a_5a_7 Patch available CNA
- org.jenkins-ci.plugins.workflow:workflow-job (Maven) Vendor— Affected before 1295.v395eb Fixed in 1295.v395eb Patch available GHSA-2wvv-phhw-qvmc
Remediation
- Fix · CNA Jenkins Pipeline: Job Plugin (Jenkins Project) Fixed in 1295.v395eb_7400005, 1289.1291.vb_7c188e7e7df, 1207.1209.v69351208a_5a_7
- Fix · GHSA-2wvv-phhw-qvmc org.jenkins-ci.plugins.workflow:workflow-job (Maven) Fixed in 1295.v395eb Advisory →
Red Hat 3 advisories
- RHSA-2023:3625 Released 2023-06-23 · Red Hat rating ImportantOpenShift Container Platform 4.10.62 security update
- Red Hat OpenShift Container Platform 4.10 jenkins-2-plugins-4.10.1685679861-1.el8, jenkins-2.401.1.1685677065-1.el8
- RHSA-2023:3663 Released 2023-06-19 · Red Hat rating Importantjenkins and jenkins-2-plugins security update
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 jenkins-2-plugins-4.11.1686831822-1.el8, jenkins-2.401.1.1686831596-3.el8
- RHSA-2023:3610 Released 2023-06-15 · Red Hat rating Importantjenkins and jenkins-2-plugins security update
- OpenShift Developer Tools and Services for OCP 4.12 jenkins-2-plugins-4.12.1686649756-1.el8, jenkins-2.401.1.1686649641-3.el8
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Will not fix |
| OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 | Fixed | RHSA-2023:3663 |
| OpenShift Developer Tools and Services for OCP 4.12 | Fixed | RHSA-2023:3610 |
| Red Hat OpenShift Container Platform 4.10 | Fixed | RHSA-2023:3625 |
Not affected: 3 products
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8
- OpenShift Developer Tools and Services for OCP 4.12
- Red Hat OpenShift Container Platform 4.10
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32977
- 2026-10-03 Alias added: GHSA-2wvv-phhw-qvmc
References
More Jenkins Pipeline vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15846 A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in… CVSS 3.1HIGH 8.8
- TI-2019-15847 A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier… CVSS 3.1HIGH 8.8
- TI-2023-11034 Cross-site scripting in Jenkins Pipeline: Build Step Plugin CVSS 3.1MEDIUM 5.4
- TI-2019-15886 A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2022-21197 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2023-32977 · CVE Program
- CVE-2023-32977 · NVD
- FIRST EPSS
- GHSA-2wvv-phhw-qvmc · GitHub Advisory Database · CC BY 4.0
- CVE-2023-32977 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences