Fides vulnerable to Path Traversal in Webserver API
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. A path traversal (directory traversal) vulnerability affects fides versions lower than version `2.15.1`, allowing remote attackers to access arbitrary files on the fides webserver container's filesystem. The vulnerability is patched in fides `2.15.1`. If the Fides webserver API is not directly accessible to attackers and is instead deployed behind a reverse proxy as recommended in Ethyca's security best practice documentation, and the reverse proxy is an AWS application load balancer, the vulnerability can't be exploited by these attackers. An AWS application load balancer will reject this attack with a 400 error. Additionally, any secrets supplied to the container using environment variables rather than a `fides.toml` configuration file are not affected by this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ethyca | fides | before 2.15.1 | 2.15.1 | Patch available | CNA |
| — | ethyca-fides (PyPI) | before 2.15.1 | 2.15.1 | Patch available | GHSA-r25m-cr6v-p9hq |
- fides Vendorethyca Affected before 2.15.1 Fixed in 2.15.1 Patch available CNA
- ethyca-fides (PyPI) Vendor— Affected before 2.15.1 Fixed in 2.15.1 Patch available GHSA-r25m-cr6v-p9hq
Remediation
- Fix · CNA fides (ethyca) Fixed in 2.15.1
- Fix · GHSA-r25m-cr6v-p9hq ethyca-fides (PyPI) Fixed in 2.15.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-36827
- 2026-10-03 Alias added: GHSA-r25m-cr6v-p9hq
References
Advisory 2
More ethyca Fides vulnerabilities
- TI-2024-30165 Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine CVSS 3.1CRITICAL 9.1
- TI-2024-30164 Fides Webserver Authentication Timing-Based Username Enumeration Vulnerability CVSS 3.1MEDIUM 5.3
- TI-2024-20599 Fides Information Disclosure Vulnerability in Privacy Center of SERVER_SIDE_FIDES_API_URL CVSS 3.1MEDIUM 5.3
- TI-2024-23262 Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints in Fides CVSS 3.1MEDIUM 6.5
- TI-2023-26088 Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides CVSS 3.1CRITICAL 9.1
- TI-2025-35700 Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation CVSS 4.0HIGH 8.6
Sources
- CVE-2023-36827 · CVE Program
- CVE-2023-36827 · NVD
- FIRST EPSS
- GHSA-r25m-cr6v-p9hq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences