Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Fides is an open-source privacy engineering platform. Prior to version 2.69.1, the OAuth client creation and update endpoints of the Fides Webserver API do not properly authorize scope assignment. This allows highly privileged users with `client:create` or `client:update` permissions to escalate their privileges to owner-level. Version 2.69.1 fixes the issue. No known workarounds are available.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ethyca | fides | before 2.69.1 | 2.69.1 | Patch available | CNA |
| — | ethyca-fides (PyPI) | before 2.69.1 | 2.69.1 | Patch available | GHSA-hjfh-p8f5-24wr |
- fides Vendorethyca Affected before 2.69.1 Fixed in 2.69.1 Patch available CNA
- ethyca-fides (PyPI) Vendor— Affected before 2.69.1 Fixed in 2.69.1 Patch available GHSA-hjfh-p8f5-24wr
Remediation
- Fix · CNA fides (ethyca) Fixed in 2.69.1
- Fix · GHSA-hjfh-p8f5-24wr ethyca-fides (PyPI) Fixed in 2.69.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-57817
- 2026-10-03 Alias added: GHSA-hjfh-p8f5-24wr
References
Advisory 2
More ethyca Fides vulnerabilities
- TI-2024-30165 Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine CVSS 3.1CRITICAL 9.1
- TI-2024-30164 Fides Webserver Authentication Timing-Based Username Enumeration Vulnerability CVSS 3.1MEDIUM 5.3
- TI-2024-20599 Fides Information Disclosure Vulnerability in Privacy Center of SERVER_SIDE_FIDES_API_URL CVSS 3.1MEDIUM 5.3
- TI-2024-23262 Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints in Fides CVSS 3.1MEDIUM 6.5
- TI-2023-26088 Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides CVSS 3.1CRITICAL 9.1
- TI-2024-25772 Inclusion of Untrusted polyfill.io Code Vulnerability in fides.js CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-57817 · CVE Program
- CVE-2025-57817 · NVD
- FIRST EPSS
- GHSA-hjfh-p8f5-24wr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences