Read the docs
TI-2024-30165 Aliases CVE-2024-45053GHSA-c34r-238x-f7qx

Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine

Priority HIGH 74CWE-1336Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-1336.

Summary

Fides is an open-source privacy engineering platform. Starting in version 2.19.0 and prior to version 2.44.0, the Email Templating feature uses Jinja2 without proper input sanitization or rendering environment restrictions, allowing for Server-Side Template Injection that grants Remote Code Execution to privileged users. A privileged user refers to an Admin UI user with the default `Owner` or `Contributor` role, who can escalate their access and execute code on the underlying Fides Webserver container where the Jinja template rendering function is executed. The vulnerability has been patched in Fides version `2.44.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There are no workarounds.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01342 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed fides (ethyca): 2.44.0ethyca-fides (PyPI): 2.44.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ethycafides2.19.0 to before 2.44.02.44.0Patch availableCNA
—ethyca-fides (PyPI)2.19.0 to before 2.44.02.44.0Patch availableGHSA-c34r-238x-f7qx
  • fides Vendorethyca Affected 2.19.0 to before 2.44.0 Fixed in 2.44.0 Patch available CNA
  • ethyca-fides (PyPI) Vendor— Affected 2.19.0 to before 2.44.0 Fixed in 2.44.0 Patch available GHSA-c34r-238x-f7qx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ethyca:fides:*:*:*:*:*:*:*:*2.19.0 to before 2.44.0Vulnerableethyca
  • cpe:2.3:a:ethyca:fides:*:*:*:*:*:*:*:* Versions 2.19.0 to before 2.44.0 Vulnerable ·ethyca

Remediation

  • Fix · CNA fides (ethyca) Fixed in 2.44.0
  • Fix · GHSA-c34r-238x-f7qx ethyca-fides (PyPI) Fixed in 2.44.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-45053
  2. 2026-10-03 Alias added: GHSA-c34r-238x-f7qx

References

  • TI-2024-30164 Fides Webserver Authentication Timing-Based Username Enumeration Vulnerability CVSS 3.1MEDIUM 5.3
  • TI-2024-20599 Fides Information Disclosure Vulnerability in Privacy Center of SERVER_SIDE_FIDES_API_URL CVSS 3.1MEDIUM 5.3
  • TI-2024-23262 Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints in Fides CVSS 3.1MEDIUM 6.5
  • TI-2023-26088 Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides CVSS 3.1CRITICAL 9.1
  • TI-2025-35700 Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation CVSS 4.0HIGH 8.6
  • TI-2024-25772 Inclusion of Untrusted polyfill.io Code Vulnerability in fides.js CVSS 3.1CRITICAL 9.8
See all 19 →

Sources