Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints in Fides
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Fides is an open-source privacy engineering platform. The Fides webserver has a number of endpoints that retrieve `ConnectionConfiguration` records and their associated `secrets` which _can_ contain sensitive data (e.g. passwords, private keys, etc.). These `secrets` are stored encrypted at rest (in the application database), and the associated endpoints are not meant to expose that sensitive data in plaintext to API clients, as it could be compromising. Fides's developers have available to them a Pydantic field-attribute (`sensitive`) that they can annotate as `True` to indicate that a given secret field should not be exposed via the API. The application has an internal function that uses `sensitive` annotations to mask the sensitive fields with a `"**********"` placeholder value. This vulnerability is due to a bug in that function, which prevented `sensitive` API model fields that were _nested_ below the root-level of a `secrets` object from being masked appropriately. Only the `BigQuery` connection configuration secrets meets these criteria: the secrets schema has a nested sensitive `keyfile_creds.private_key` property that is exposed in plaintext via the APIs. Connection types other than `BigQuery` with sensitive fields at the root-level that are not nested are properly masked with the placeholder and are not affected by this vulnerability. This vulnerability has been patched in Fides version 2.37.0. Users are advised to upgrade to this version or later to secure their systems against this threat. Users are also advised to rotate any Google Cloud secrets used for BigQuery integrations in their Fides deployments. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ethyca | fides | before 2.37.0 | 2.37.0 | Patch available | CNA |
| — | ethyca-fides (PyPI) | before 2.37.0 | 2.37.0 | Patch available | GHSA-rcvg-jj3g-rj7c |
- fides Vendorethyca Affected before 2.37.0 Fixed in 2.37.0 Patch available CNA
- ethyca-fides (PyPI) Vendor— Affected before 2.37.0 Fixed in 2.37.0 Patch available GHSA-rcvg-jj3g-rj7c
Remediation
- Fix · CNA fides (ethyca) Fixed in 2.37.0
- Fix · GHSA-rcvg-jj3g-rj7c ethyca-fides (PyPI) Fixed in 2.37.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-35189
- 2026-10-03 Alias added: GHSA-rcvg-jj3g-rj7c
References
More ethyca Fides vulnerabilities
- TI-2024-30165 Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine CVSS 3.1CRITICAL 9.1
- TI-2024-30164 Fides Webserver Authentication Timing-Based Username Enumeration Vulnerability CVSS 3.1MEDIUM 5.3
- TI-2024-20599 Fides Information Disclosure Vulnerability in Privacy Center of SERVER_SIDE_FIDES_API_URL CVSS 3.1MEDIUM 5.3
- TI-2023-26088 Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides CVSS 3.1CRITICAL 9.1
- TI-2025-35700 Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation CVSS 4.0HIGH 8.6
- TI-2024-25772 Inclusion of Untrusted polyfill.io Code Vulnerability in fides.js CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-35189 · CVE Program
- CVE-2024-35189 · NVD
- FIRST EPSS
- GHSA-rcvg-jj3g-rj7c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences