Read the docs
TI-2023-21919 Aliases CVE-2023-41319GHSA-p6p2-qq95-vq5h

Remote Code Execution in Custom Integration Upload in Fides

Priority MEDIUM 42CWE-693Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass, Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-693 and CWE-94.

Summary

Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. The Fides webserver API allows custom integrations to be uploaded as a ZIP file. This ZIP file must contain YAML files, but Fides can be configured to also accept the inclusion of custom Python code in it. The custom code is executed in a restricted, sandboxed environment, but the sandbox can be bypassed to execute any arbitrary code. The vulnerability allows the execution of arbitrary code on the target system within the context of the webserver python process owner on the webserver container, which by default is `root`, and leverage that access to attack underlying infrastructure and integrated systems. This vulnerability affects Fides versions `2.11.0` through `2.19.0`. Exploitation is limited to API clients with the `CONNECTOR_TEMPLATE_REGISTER` authorization scope. In the Fides Admin UI this scope is restricted to highly privileged users, specifically root users and users with the owner role. Exploitation is only possible if the security configuration parameter `allow_custom_connector_functions` is enabled by the user deploying the Fides webserver container, either in `fides.toml` or by setting the env var `FIDES__SECURITY__ALLOW_CUSTOM_CONNECTOR_FUNCTIONS=True`. By default this configuration parameter is disabled. The vulnerability has been patched in Fides version `2.19.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. Users unable to upgrade should ensure that `allow_custom_connector_functions` in `fides.toml` and the `FIDES__SECURITY__ALLOW_CUSTOM_CONNECTOR_FUNCTIONS` are both either unset or explicit set to `False`.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00936 61st percentileScored 2026-11-07
Fix Fixed fides (ethyca): 2.19.0ethyca-fides (PyPI): 2.19.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ethycafides2.11.0 to before 2.19.02.19.0Patch availableCNA
—ethyca-fides (PyPI)2.11.0 to before 2.19.02.19.0Patch availableGHSA-p6p2-qq95-vq5h
  • fides Vendorethyca Affected 2.11.0 to before 2.19.0 Fixed in 2.19.0 Patch available CNA
  • ethyca-fides (PyPI) Vendor— Affected 2.11.0 to before 2.19.0 Fixed in 2.19.0 Patch available GHSA-p6p2-qq95-vq5h

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ethyca:fides:*:*:*:*:*:*:*:*2.11.0 to before 2.19.0Vulnerableethyca
  • cpe:2.3:a:ethyca:fides:*:*:*:*:*:*:*:* Versions 2.11.0 to before 2.19.0 Vulnerable ·ethyca

Remediation

  • Fix · CNA fides (ethyca) Fixed in 2.19.0
  • Fix · GHSA-p6p2-qq95-vq5h ethyca-fides (PyPI) Fixed in 2.19.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-41319
  2. 2026-10-03 Alias added: GHSA-p6p2-qq95-vq5h

References

  • TI-2024-30165 Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine CVSS 3.1CRITICAL 9.1
  • TI-2024-30164 Fides Webserver Authentication Timing-Based Username Enumeration Vulnerability CVSS 3.1MEDIUM 5.3
  • TI-2024-20599 Fides Information Disclosure Vulnerability in Privacy Center of SERVER_SIDE_FIDES_API_URL CVSS 3.1MEDIUM 5.3
  • TI-2024-23262 Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints in Fides CVSS 3.1MEDIUM 6.5
  • TI-2023-26088 Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides CVSS 3.1CRITICAL 9.1
  • TI-2025-35700 Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation CVSS 4.0HIGH 8.6
See all 19 →

Sources