Read the docs
TI-2023-22625 Aliases CVE-2023-42460GHSA-cx2q-hfxr-rj97

_abi_decode input not validated in complex expressions in Vyper

Priority LOW 34CWE-682Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Vyper is a Pythonic Smart Contract Language for the EVM. The `_abi_decode()` function does not validate input when it is nested in an expression. Uses of `_abi_decode()` can be constructed which allow for bounds checking to be bypassed resulting in incorrect results. This issue has not yet been fixed, but a fix is expected in release `0.3.10`. Users are advised to reference pull request #3626.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00671 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed vyper (vyperlang): 0.3.10vyper (PyPI): 0.3.10

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vyperlangvyper0.3.4 to before 0.3.100.3.10Patch availableCNA
—vyper (PyPI)0.3.4 to before 0.3.100.3.10Patch availableGHSA-cx2q-hfxr-rj97
  • vyper Vendorvyperlang Affected 0.3.4 to before 0.3.10 Fixed in 0.3.10 Patch available CNA
  • vyper (PyPI) Vendor— Affected 0.3.4 to before 0.3.10 Fixed in 0.3.10 Patch available GHSA-cx2q-hfxr-rj97

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vyperlang:vyper:*:*:*:*:*:python:*:*0.3.4 to before 0.3.10Vulnerablevyperlang
  • cpe:2.3:a:vyperlang:vyper:*:*:*:*:*:python:*:* Versions 0.3.4 to before 0.3.10 Vulnerable ·vyperlang

Remediation

  • Fix · CNA vyper (vyperlang) Fixed in 0.3.10
  • Fix · GHSA-cx2q-hfxr-rj97 vyper (PyPI) Fixed in 0.3.10 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-42460
  2. 2026-10-03 Alias added: GHSA-cx2q-hfxr-rj97

References

  • TI-2024-16182 Vyper bounds check on built-in `slice()` function can be overflowed CVSS 3.1CRITICAL 9.8
  • TI-2024-14992 concat built-in can corrupt memory in vyper CVSS 3.1CRITICAL 9.8
  • TI-2024-16184 Vyper array negative index vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2022-08657 Integer bounds error in Vyper CVSS 3.1CRITICAL 9.8
  • TI-2022-11796 Multiple evaluation of contract address in call in vyper CVSS 3.1HIGH 8.2
  • TI-2024-21531 vyper performs double eval of the argument of sqrt CVSS 3.1MEDIUM 5.3
See all 37 →

Sources