Read the docs
TI-2024-01248 Aliases CVE-2024-1339GHSA-8rw6-gfwq-fxcg

ImageRecycle pdf & image compression <= 3.1.13 - Cross-Site Request Forgery to Plugin Data Removal in reinitialize

Priority LOW 19CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.

Summary

The ImageRecycle pdf & image compression plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.1.13. This is due to missing or incorrect nonce validation on the reinitialize function. This makes it possible for unauthenticated attackers to remove all plugin data via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00208 11th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
imagerecycleImageRecycle pdf & image compressionup to 3.1.13—No fix listedCNA
  • ImageRecycle pdf & image compression Vendorimagerecycle Affected up to 3.1.13 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:imagerecycle:imagerecycle_pdf_\&_image_compression:*:*:*:*:*:wordpress:*:*before 3.1.14Vulnerableimagerecycle
  • cpe:2.3:a:imagerecycle:imagerecycle_pdf_\&_image_compression:*:*:*:*:*:wordpress:*:* Versions before 3.1.14 Vulnerable ·imagerecycle

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-1339
  2. 2026-10-03 Alias added: GHSA-8rw6-gfwq-fxcg

References

  • TI-2024-36355 WordPress ImageRecycle pdf & image compression plugin <= 3.1.16 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2023-21066 WordPress ImageRecycle pdf & image compression Plugin <= 3.1.11 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2023-14330 WordPress ImageRecycle pdf & image compression Plugin <= 3.1.10 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2024-06148 ImageRecycle pdf & image compression <= 3.1.14 - Missing Authorization in Several AJAX Actions CVSS 3.1MEDIUM 5.0
  • TI-2024-07528 ImageRecycle pdf & image compression <= 3.1.14 - Cross-Site Request in Several AJAX Actions CVSS 3.1MEDIUM 4.7
  • TI-2024-01243 ImageRecycle pdf & image compression <= 3.1.13 - Cross-Site Request Forgery to Settings Update in enableOptimization CVSS 3.1MEDIUM 4.3
See all 14 →

Sources