Read the docs
TI-2024-01592 Aliases CVE-2024-1712GHSA-wq89-j555-p43g

Carousel Slider < 2.2.7 - Editor+ Stored XSS

Priority MEDIUM 55CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Carousel Slider WordPress plugin before 2.2.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00484 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Carousel Slider (Unknown): 2.2.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownCarousel Sliderbefore 2.2.72.2.7Patch availableCNA
  • Carousel Slider VendorUnknown Affected before 2.2.7 Fixed in 2.2.7 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:majeedraza:carousel_slider:*:*:*:*:*:wordpress:*:*before 2.2.7VulnerableMajeed Raza
  • cpe:2.3:a:majeedraza:carousel_slider:*:*:*:*:*:wordpress:*:* Versions before 2.2.7 Vulnerable ·Majeed Raza

Remediation

  • Fix · CNA Carousel Slider (Unknown) Fixed in 2.2.7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-1712
  2. 2026-10-03 Alias added: GHSA-wq89-j555-p43g

References

  • TI-2024-06352 Carousel Slider < 2.2.14 - Editor+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-03453 Carousel Slider < 2.2.10 - Editor+ Stored XSS CVSS 3.1MEDIUM 4.7
  • TI-2023-22241 WordPress Carousel Slider plugin <= 2.2.2 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
  • TI-2024-04074 Carousel Slider < 2.2.11 - Editor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2024-30341 Cross-site request forgery in Sayful Islam Carousel Slider CVSS 3.1MEDIUM 4.3
  • TI-2024-30342 Cross-site request forgery in Sayful Islam Carousel Slider CVSS 3.1MEDIUM 4.3

Sources