Carousel Slider < 2.2.14 - Editor+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Carousel Slider WordPress plugin before 2.2.4 does not sanitise and escape some of its settings, which could allow high privilege users such as editors to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00339 27th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Carousel Slider (Unknown): 2.2.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Carousel Slider | before 2.2.4 | 2.2.4 | Patch available | CNA |
- Carousel Slider VendorUnknown Affected before 2.2.4 Fixed in 2.2.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:majeedraza:carousel_slider:*:*:*:*:*:wordpress:*:* | before 2.2.14 | Vulnerable | Majeed Raza |
- cpe:2.3:a:majeedraza:carousel_slider:*:*:*:*:*:wordpress:*:* Versions before 2.2.14 Vulnerable ·Majeed Raza
Remediation
- Fix · CNA Carousel Slider (Unknown) Fixed in 2.2.4
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6850
- 2026-10-03 Alias added: GHSA-gq5m-j7gp-3x7q
References
More Majeed Raza Carousel Slider vulnerabilities
- TI-2024-03453 Carousel Slider < 2.2.10 - Editor+ Stored XSS CVSS 3.1MEDIUM 4.7
- TI-2024-01592 Carousel Slider < 2.2.7 - Editor+ Stored XSS CVSS 3.1MEDIUM 4.7
- TI-2023-22241 WordPress Carousel Slider plugin <= 2.2.2 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
- TI-2024-04074 Carousel Slider < 2.2.11 - Editor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-30341 Cross-site request forgery in Sayful Islam Carousel Slider CVSS 3.1MEDIUM 4.3
- TI-2024-30342 Cross-site request forgery in Sayful Islam Carousel Slider CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-6850 · CVE Program
- CVE-2024-6850 · NVD
- FIRST EPSS
- GHSA-gq5m-j7gp-3x7q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences