Read the docs
TI-2024-01771 Aliases CVE-2024-1902GHSA-prc3-79c5-8h62

Session Reuse Vulnerability in lunary-ai/lunary

Priority HIGH 72CWE-821Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

lunary-ai/lunary is vulnerable to a session reuse attack, allowing a removed user to change the organization name without proper authorization. The vulnerability stems from the lack of validation to check if a user is still part of an organization before allowing them to make changes. An attacker can exploit this by using an old authorization token to send a PATCH request, modifying the organization's name even after being removed from the organization. This issue is due to incorrect synchronization and affects the orgs.patch route.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00387 33rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed lunary-ai/lunary (lunary-ai): 1.2.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
lunary-ailunary-ai/lunarybefore 1.2.81.2.8Patch availableCNA
  • lunary-ai/lunary Vendorlunary-ai Affected before 1.2.8 Fixed in 1.2.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:lunary:lunary:*:*:*:*:*:*:*:*before 1.2.8Vulnerablelunary-ai
  • cpe:2.3:a:lunary:lunary:*:*:*:*:*:*:*:* Versions before 1.2.8 Vulnerable ·lunary-ai

Remediation

  • Fix · CNA lunary-ai/lunary (lunary-ai) Fixed in 1.2.8

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    lunary-ai/lunary 1.2.8

    2 records Highest priority Priority HIGH 2 HIGH

    Other records, highest priority first

    • TI-2024-01619 Improper Authorization in lunary-ai/lunaryPriority HIGH 80

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-1902
  2. 2026-10-03 Alias added: GHSA-prc3-79c5-8h62

References

  • TI-2024-08445 Improper Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-06910 SQL Injection in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-03859 Incorrect Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-06928 Improper Access Control in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
  • TI-2024-03267 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
  • TI-2024-03266 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
See all 68 →

Sources