Stored XSS in zenml-io/zenml
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field. By injecting malicious payloads into this field, an attacker could send harmful messages to other users, potentially compromising their accounts. The vulnerability affects version 0.55.3 and was fixed in version 0.56.2. The impact of exploiting this vulnerability could lead to user account compromise.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| zenml-io | zenml-io/zenml | before 0.56.2 | 0.56.2 | Patch available | CNA |
| — | zenml (PyPI) | before 0.56.2 | 0.56.2 | Patch available | GHSA-vwgf-7f9h-h499 |
- zenml-io/zenml Vendorzenml-io Affected before 0.56.2 Fixed in 0.56.2 Patch available CNA
- zenml (PyPI) Vendor— Affected before 0.56.2 Fixed in 0.56.2 Patch available GHSA-vwgf-7f9h-h499
Remediation
- Fix · CNA zenml-io/zenml (zenml-io) Fixed in 0.56.2
- Fix · GHSA-vwgf-7f9h-h499 zenml (PyPI) Fixed in 0.56.2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
zenml-io/zenml 0.56.2
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2024-01894 Improper Authorization in zenml-io/zenmlPriority MEDIUM 62
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2171
- 2026-10-03 Alias added: GHSA-vwgf-7f9h-h499
References
More zenml-io Zenml vulnerabilities
- TI-2024-16924 ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote… CVSS 3.1HIGH 8.8
- TI-2024-01939 Directory Traversal in zenml-io/zenml CVSS 3.1CRITICAL 9.9
- TI-2024-08664 Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml CVSS 3.0HIGH 7.5
- TI-2024-04355 Insufficient Session Expiration in zenml-io/zenml CVSS 3.1HIGH 8.8
- TI-2025-07692 Path Traversal in zenml-io/zenml CVSS 3.1HIGH 7.8
- TI-2024-01894 Improper Authorization in zenml-io/zenml CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-2171 · CVE Program
- CVE-2024-2171 · NVD
- FIRST EPSS
- GHSA-vwgf-7f9h-h499 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences