Improper Authentication in zenml-io/zenml
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| zenml-io | zenml-io/zenml | before 0.56.3 | 0.56.3 | Patch available | CNA |
| — | zenml (PyPI) | before 0.56.3 | 0.56.3 | Patch available | GHSA-j527-v579-m98h |
- zenml-io/zenml Vendorzenml-io Affected before 0.56.3 Fixed in 0.56.3 Patch available CNA
- zenml (PyPI) Vendor— Affected before 0.56.3 Fixed in 0.56.3 Patch available GHSA-j527-v579-m98h
Remediation
- Fix · CNA zenml-io/zenml (zenml-io) Fixed in 0.56.3
- Fix · GHSA-j527-v579-m98h zenml (PyPI) Fixed in 0.56.3 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
zenml-io/zenml 0.56.3
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2024-02214 Clickjacking Vulnerability in zenml-io/zenmlPriority MEDIUM 60
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2213
- 2026-10-03 Alias added: GHSA-j527-v579-m98h
References
More zenml-io Zenml vulnerabilities
- TI-2024-16924 ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote… CVSS 3.1HIGH 8.8
- TI-2024-01939 Directory Traversal in zenml-io/zenml CVSS 3.1CRITICAL 9.9
- TI-2024-08664 Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml CVSS 3.0HIGH 7.5
- TI-2024-04355 Insufficient Session Expiration in zenml-io/zenml CVSS 3.1HIGH 8.8
- TI-2025-07692 Path Traversal in zenml-io/zenml CVSS 3.1HIGH 7.8
- TI-2024-01894 Improper Authorization in zenml-io/zenml CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-2213 · CVE Program
- CVE-2024-2213 · NVD
- FIRST EPSS
- GHSA-j527-v579-m98h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences