WooCommerce Product Filter < 1.4.4 - Filter Deletion via CSRF
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
Themify WordPress plugin before 1.4.4 does not have CSRF check in its bulk action, which could allow attackers to make logged in users delete arbitrary filters via CSRF attack, granted they know the related filter slugs
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Themify | before 1.4.4 | 1.4.4 | Patch available | CNA |
- Themify VendorUnknown Affected before 1.4.4 Fixed in 1.4.4 Patch available CNA
Remediation
- Fix · CNA Themify (Unknown) Fixed in 1.4.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Themify 1.4.4
3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2024-02100 WooCommerce Product Filter < 1.4.4 - Reflected XSSPriority MEDIUM 55
- TI-2024-02115 WooCommerce Product Filter < 1.4.4 - Admin+ Stored XSSPriority LOW 28
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2262
- 2026-10-03 Alias added: GHSA-mqx4-g9cq-jvc6
References
More themifyme Woocommerce Product Filter vulnerabilities
- TI-2024-02100 WooCommerce Product Filter < 1.4.4 - Reflected XSS CVSS 3.1MEDIUM 4.8
- TI-2022-01405 Themify - WooCommerce Product Filter < 1.3.8 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-02115 WooCommerce Product Filter < 1.4.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2024-29635 WordPress Themify plugin <= 1.5.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9
Sources
- CVE-2024-2262 · CVE Program
- CVE-2024-2262 · NVD
- FIRST EPSS
- GHSA-mqx4-g9cq-jvc6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences