WooCommerce Product Filter < 1.4.4 - Reflected XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Themify WordPress plugin before 1.4.4 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Themify | before 1.4.4 | 1.4.4 | Patch available | CNA |
- Themify VendorUnknown Affected before 1.4.4 Fixed in 1.4.4 Patch available CNA
Remediation
- Fix · CNA Themify (Unknown) Fixed in 1.4.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Themify 1.4.4
3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2024-02099 WooCommerce Product Filter < 1.4.4 - Filter Deletion via CSRFPriority MEDIUM 55
- TI-2024-02115 WooCommerce Product Filter < 1.4.4 - Admin+ Stored XSSPriority LOW 28
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2263
- 2026-10-03 Alias added: GHSA-363m-3jp4-qg24
References
More themifyme Woocommerce Product Filter vulnerabilities
- TI-2024-02099 WooCommerce Product Filter < 1.4.4 - Filter Deletion via CSRF CVSS 3.1MEDIUM 4.7
- TI-2022-01405 Themify - WooCommerce Product Filter < 1.3.8 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-02115 WooCommerce Product Filter < 1.4.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2024-29635 WordPress Themify plugin <= 1.5.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9
Sources
- CVE-2024-2263 · CVE Program
- CVE-2024-2263 · NVD
- FIRST EPSS
- GHSA-363m-3jp4-qg24 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences