Responsive Contact Form Builder & Lead Generation Plugin <= 1.8.9 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Responsive Contact Form Builder & Lead Generation Plugin WordPress plugin through 1.8.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Responsive Contact Form Builder & Lead Generation Plugin | up to 1.8.9 | — | No fix listed | CNA |
- Responsive Contact Form Builder & Lead Generation Plugin VendorUnknown Affected up to 1.8.9 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3637
- 2026-10-03 Alias added: GHSA-pvfc-97vc-2gh2
References
More themehunk Contact Form & Lead Form Elementor Builder vulnerabilities
- TI-2024-09703 Lead Form Builder < 1.9.8 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2022-07332 Contact Form & Lead Form Elementor Builder < 1.7.0 - Multiple Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2022-07333 Contact Form & Lead Form Elementor Builder Plugin < 1.7.4 - Multiple Subscriber+ Settings Update CVSS 3.1MEDIUM 4.3
- TI-2021-07246 Contact Form & Lead Form Elementor Builder < 1.6.4 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-3637 · CVE Program
- CVE-2024-3637 · NVD
- FIRST EPSS
- GHSA-pvfc-97vc-2gh2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences