Lead Form Builder < 1.9.8 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Responsive Contact Form Builder & Lead Generation Plugin WordPress plugin before 1.9.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Responsive Contact Form Builder & Lead Generation Plugin | before 1.9.8 | 1.9.8 | Patch available | CNA |
- Responsive Contact Form Builder & Lead Generation Plugin VendorUnknown Affected before 1.9.8 Fixed in 1.9.8 Patch available CNA
Remediation
- Fix · CNA Responsive Contact Form Builder & Lead Generation Plugin (Unknown) Fixed in 1.9.8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10475
- 2026-10-03 Alias added: GHSA-m8jc-qh4f-52fp
References
More themehunk Contact Form & Lead Form Elementor Builder vulnerabilities
- TI-2024-03392 Responsive Contact Form Builder & Lead Generation Plugin <= 1.8.9 - Admin+ Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2022-07332 Contact Form & Lead Form Elementor Builder < 1.7.0 - Multiple Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2022-07333 Contact Form & Lead Form Elementor Builder Plugin < 1.7.4 - Multiple Subscriber+ Settings Update CVSS 3.1MEDIUM 4.3
- TI-2021-07246 Contact Form & Lead Form Elementor Builder < 1.6.4 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-10475 · CVE Program
- CVE-2024-10475 · NVD
- FIRST EPSS
- GHSA-m8jc-qh4f-52fp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences