Survey Maker < 4.2.9 - Admin+ Stored XSS via Plugin Settings
Priority LOW 22CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Survey Maker WordPress plugin before 4.2.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00422 36th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Survey Maker (Unknown): 4.2.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Survey Maker | before 4.2.9 | 4.2.9 | Patch available | CNA |
- Survey Maker VendorUnknown Affected before 4.2.9 Fixed in 4.2.9 Patch available CNA
Remediation
- Fix · CNA Survey Maker (Unknown) Fixed in 4.2.9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4061
- 2026-10-03 Alias added: GHSA-6fj9-cq25-9x7h
References
More Ays Pro Survey Maker vulnerabilities
- TI-2023-09325 SQL injection in Survey Maker WordPress Plugin CVSS 3.1HIGH 8.8
- TI-2023-02404 Survey Maker < 3.4.7 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2023-08872 WordPress Survey Maker plugin <= 3.2.0 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2021-06748 Survey Maker < 1.5.6 - Authenticated Blind SQL Injections CVSS 3.1HIGH 8.8
- TI-2023-00036 Survey Maker – Best WordPress Survey Plugin <= 3.1.3 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
- TI-2024-19685 WordPress Survey Maker plugin <= 4.0.6 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2024-4061 · CVE Program
- CVE-2024-4061 · NVD
- FIRST EPSS
- GHSA-6fj9-cq25-9x7h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences