Read the docs
TI-2024-04014 Aliases CVE-2024-4311GHSA-j3vq-pmp5-r5xj

Lack of login attempt rate-limiting in zenml-io/zenml

Priority MEDIUM 58CWE-770Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
High
Impact type
Denial of service
Confidentiality · integrity · availability
Low · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-770.

Summary

zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the 'Update Password' function, allowing them to take over the user's account. This vulnerability is due to the absence of rate-limiting on the '/api/v1/current-user' endpoint, which does not restrict the number of attempts an attacker can make to guess the current password. Successful exploitation results in the attacker being able to change the password and take control of the account.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00508 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed zenml-io/zenml (zenml-io): 0.57.0zenml (PyPI): 0.57.0rc2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
zenml-iozenml-io/zenmlbefore 0.57.00.57.0Patch availableCNA
—zenml (PyPI)before 0.57.0rc20.57.0rc2Patch availableGHSA-j3vq-pmp5-r5xj
  • zenml-io/zenml Vendorzenml-io Affected before 0.57.0 Fixed in 0.57.0 Patch available CNA
  • zenml (PyPI) Vendor— Affected before 0.57.0rc2 Fixed in 0.57.0rc2 Patch available GHSA-j3vq-pmp5-r5xj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:zenml:zenml:0.56.4:*:*:*:*:*:*:*0.56.4Vulnerablezenml-io
  • cpe:2.3:a:zenml:zenml:0.56.4:*:*:*:*:*:*:* Versions 0.56.4 Vulnerable ·zenml-io

Remediation

  • Fix · CNA zenml-io/zenml (zenml-io) Fixed in 0.57.0
  • Fix · GHSA-j3vq-pmp5-r5xj zenml (PyPI) Fixed in 0.57.0rc2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-4311
  2. 2026-10-03 Alias added: GHSA-j3vq-pmp5-r5xj

References

  • TI-2024-16924 ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote… CVSS 3.1HIGH 8.8
  • TI-2024-01939 Directory Traversal in zenml-io/zenml CVSS 3.1CRITICAL 9.9
  • TI-2024-08664 Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml CVSS 3.0HIGH 7.5
  • TI-2024-04355 Insufficient Session Expiration in zenml-io/zenml CVSS 3.1HIGH 8.8
  • TI-2025-07692 Path Traversal in zenml-io/zenml CVSS 3.1HIGH 7.8
  • TI-2024-01894 Improper Authorization in zenml-io/zenml CVSS 3.1MEDIUM 6.5
See all 13 →

Sources