Read the docs
TI-2024-04766 Aliases CVE-2024-5130GHSA-f8mv-jphx-3r7g

Incorrect Authorization in lunary-ai/lunary

Priority LOW 39CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-862.

Summary

An Incorrect Authorization vulnerability exists in lunary-ai/lunary versions up to and including 1.2.2, which allows unauthenticated users to delete any dataset. The vulnerability is due to the lack of proper authorization checks in the dataset deletion endpoint. Specifically, the endpoint does not verify if the provided project ID belongs to the current user, thereby allowing any dataset to be deleted without proper authentication. This issue was fixed in version 1.2.8.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00484 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed lunary-ai/lunary (lunary-ai): 1.2.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
lunary-ailunary-ai/lunarybefore 1.2.81.2.8Patch availableCNA
  • lunary-ai/lunary Vendorlunary-ai Affected before 1.2.8 Fixed in 1.2.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:lunary:lunary:*:*:*:*:*:*:*:*before 1.2.8Vulnerablelunary-ai
  • cpe:2.3:a:lunary:lunary:*:*:*:*:*:*:*:* Versions before 1.2.8 Vulnerable ·lunary-ai

Remediation

  • Fix · CNA lunary-ai/lunary (lunary-ai) Fixed in 1.2.8

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    lunary-ai/lunary 1.2.8

    2 records Highest priority Priority HIGH 1 HIGH, 1 LOW

    Other records, highest priority first

    • TI-2024-04765 Privilege Escalation Vulnerability in lunary-ai/lunaryPriority HIGH 75

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-5130
  2. 2026-10-03 Alias added: GHSA-f8mv-jphx-3r7g

References

  • TI-2024-08445 Improper Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-06910 SQL Injection in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-03859 Incorrect Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-06928 Improper Access Control in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
  • TI-2024-03267 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
  • TI-2024-03266 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
See all 68 →

Sources