Read the docs
TI-2024-05304 Aliases CVE-2024-5710GHSA-qqcv-vg9f-5rr3

Improper Access Control in Team Management in berriai/litellm

Priority MEDIUM 62CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

berriai/litellm version 1.34.34 is vulnerable to improper access control in its team management functionality. This vulnerability allows attackers to perform unauthorized actions such as creating, updating, viewing, deleting, blocking, and unblocking any teams, as well as adding or deleting any member to or from any teams. The vulnerability stems from insufficient access control checks in various team management endpoints, enabling attackers to exploit these functionalities without proper authorization.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00406 35th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed litellm (PyPI): 1.40.15

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
BerriAIberriai/litellmup to latest—No fix listedCNA
—litellm (PyPI)before 1.40.151.40.15Patch availableGHSA-qqcv-vg9f-5rr3
  • berriai/litellm VendorBerriAI Affected up to latest Fixed in — No fix listed CNA
  • litellm (PyPI) Vendor— Affected before 1.40.15 Fixed in 1.40.15 Patch available GHSA-qqcv-vg9f-5rr3

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:litellm:litellm:1.34.34:*:*:*:*:*:*:*1.34.34VulnerableBerriAI
  • cpe:2.3:a:litellm:litellm:1.34.34:*:*:*:*:*:*:* Versions 1.34.34 Vulnerable ·BerriAI

Remediation

  • Fix · GHSA-qqcv-vg9f-5rr3 litellm (PyPI) Fixed in 1.40.15 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-5710
  2. 2026-10-03 Alias added: GHSA-qqcv-vg9f-5rr3

References

  • TI-2026-26015 Trivy ecosystem supply chain briefly compromised KEVCVSS 4.0CRITICAL 9.4
  • TI-2026-30529 LiteLLM: SQL injection in Proxy API key verification KEVCVSS 4.0CRITICAL 9.3
  • TI-2026-30582 LiteLLM: Authenticated command execution via MCP stdio test endpoints KEVCVSS 4.0HIGH 8.7
  • TI-2026-42639 LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback KEVCVSS 4.0HIGH 8.8
  • TI-2024-05340 Remote Code Execution in BerriAI/litellm CVSS 3.1CRITICAL 9.8
  • TI-2024-02760 Server-Side Template Injection in BerriAI/litellm CVSS 3.0CRITICAL 9.8
See all 36 →

Sources