WP SVG Images <= 4.3 - Authenticated (Author+) Stored Cross-Site Scripting via SVG
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The WP SVG Images plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘type’ parameter in all versions up to, and including, 4.3 due to insufficient input sanitization. This makes it possible for authenticated attackers, with Author-level access and above, who have permissions to upload sanitized files, to bypass SVG sanitization and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A bypass to the patch in version 4.3 was discovered and fixed completely in version 4.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ShortPixel | WP SVG Images | up to 4.3 | — | No fix listed | CNA |
- WP SVG Images VendorShortPixel Affected up to 4.3 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5945
- 2026-10-03 Alias added: GHSA-jm7q-rxr5-2rpf
References
Other 3
- https://plugins.trac.wordpress.org/browser/wp-svg-images/trunk/wp-svg-images.php#L111
- https://plugins.trac.wordpress.org/browser/wp-svg-images/trunk/wp-svg-images.php#L313
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3227378%40wp-svg-images&new=3227378%40wp-svg-images&sfp_email=&sfph_mail=
More ShortPixel vulnerabilities
- TI-2023-04280 Enable Media Replace < 4.1.3 - Author+ PHP Object Injection CVSS 3.1HIGH 8.8
- TI-2023-00241 Enable Media Replace < 4.0.2 - Author+ Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2023-00318 ShortPixel Adaptive Images < 3.6.3 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2026-14215 ShortPixel Image Optimizer <= 6.5.5 - Authenticated (Author+) PHP Object Injection via Nested JSON Post Content CVSS 3.1HIGH 8.8
- TI-2026-83296 PHP object injection in Enable Media Replace WordPress plugin CVSS 3.1HIGH 8.8
- TI-2023-15794 WordPress ShortPixel Adaptive Images Plugin <= 3.7.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2024-5945 · CVE Program
- CVE-2024-5945 · NVD
- FIRST EPSS
- GHSA-jm7q-rxr5-2rpf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences