TrueBooker < 1.0.3 - Multiple Unauthenticated SQLi
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.
Summary
The TrueBooker WordPress plugin before 1.0.3 does not properly sanitise and escape a parameter before using it in a SQL statement via an AJAX action available to unauthenticated users, leading to a SQL injection.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | TrueBooker | before 1.0.3 | 1.0.3 | Patch available | CNA |
- TrueBooker VendorUnknown Affected before 1.0.3 Fixed in 1.0.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:themetechmount:truebooker:*:*:*:*:*:wordpress:*:* | up to 1.0.2 | Vulnerable | themetechmount |
- cpe:2.3:a:themetechmount:truebooker:*:*:*:*:*:wordpress:*:* Versions up to 1.0.2 Vulnerable ·themetechmount
Remediation
- Fix · CNA TrueBooker (Unknown) Fixed in 1.0.3
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
TrueBooker 1.0.3
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2024-06424 TrueBooker < 1.0.3 - Settings Update via CSRFPriority MEDIUM 53
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6924
- 2026-10-03 Alias added: GHSA-xwhw-83c9-38cf
References
More themetechmount Truebooker vulnerabilities
- TI-2024-06424 TrueBooker < 1.0.3 - Settings Update via CSRF CVSS 3.1MEDIUM 4.3
- TI-2025-30040 WordPress TrueBooker plugin <= 1.0.7 - Cross Site Request Forgery (CSRF) Vulnerability CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-6924 · CVE Program
- CVE-2024-6924 · NVD
- FIRST EPSS
- GHSA-xwhw-83c9-38cf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences