TrueBooker < 1.0.3 - Settings Update via CSRF
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
The TrueBooker WordPress plugin before 1.0.3 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | TrueBooker | before 1.0.3 | 1.0.3 | Patch available | CNA |
- TrueBooker VendorUnknown Affected before 1.0.3 Fixed in 1.0.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:themetechmount:truebooker:*:*:*:*:*:wordpress:*:* | up to 1.0.2 | Vulnerable | themetechmount |
- cpe:2.3:a:themetechmount:truebooker:*:*:*:*:*:wordpress:*:* Versions up to 1.0.2 Vulnerable ·themetechmount
Remediation
- Fix · CNA TrueBooker (Unknown) Fixed in 1.0.3
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
TrueBooker 1.0.3
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2024-06423 TrueBooker < 1.0.3 - Multiple Unauthenticated SQLiPriority HIGH 82
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6925
- 2026-10-03 Alias added: GHSA-rf9h-8cx8-5xww
References
More themetechmount Truebooker vulnerabilities
- TI-2024-06423 TrueBooker < 1.0.3 - Multiple Unauthenticated SQLi CVSS 3.1CRITICAL 9.8
- TI-2025-30040 WordPress TrueBooker plugin <= 1.0.7 - Cross Site Request Forgery (CSRF) Vulnerability CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-6925 · CVE Program
- CVE-2024-6925 · NVD
- FIRST EPSS
- GHSA-rf9h-8cx8-5xww · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences