Appointment Booking Calendar < 1.6.7.43 - Admin+ Template Injection to RCE
Priority HIGH 67Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Appointment Booking Calendar WordPress plugin before 1.6.7.43 does not escape template syntax provided via user input, leading to Twig Template Injection which further exploited can result to remote code Execution by high privilege such as admins
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01138 66th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin (Unknown): 1.6.7.43
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin | before 1.6.7.43 | 1.6.7.43 | Patch available | CNA |
- Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin VendorUnknown Affected before 1.6.7.43 Fixed in 1.6.7.43 Patch available CNA
Remediation
- Fix · CNA Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin (Unknown) Fixed in 1.6.7.43
Timeline
- 2026-10-02 Threatist record created from CVE-2024-7129
- 2026-10-03 Alias added: GHSA-m8mp-83qq-7j4f
References
More Nsqua Simply Schedule Appointments vulnerabilities
- TI-2024-07301 Appointment Booking Calendar < 1.6.7.55 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-07300 Appointment Booking Calendar < 1.6.7.55 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-27756 WordPress Simply Schedule Appointments Plugin < 1.6.6.1 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
- TI-2022-02189 Simply Schedule Appointments < 1.5.7.7 - Unauthenticated Email Address Disclosure CVSS 3.1MEDIUM 5.3
- TI-2022-02190 Simply Schedule Appointments < 1.5.7.7 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2024-7129 · CVE Program
- CVE-2024-7129 · NVD
- FIRST EPSS
- GHSA-m8mp-83qq-7j4f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences