Pricing Tables WordPress Plugin – Easy Pricing Tables <= 3.2.5 - Reflected Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Pricing Tables WordPress Plugin – Easy Pricing Tables plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 3.2.5. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fatcatapps | Pricing Table WordPress Plugin – Easy Pricing Tables | up to 3.2.5 | — | No fix listed | CNA |
- Pricing Table WordPress Plugin – Easy Pricing Tables Vendorfatcatapps Affected up to 3.2.5 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8871
- 2026-10-03 Alias added: GHSA-r5f9-2fp7-f77w
References
Other 3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a5e4f40b-c028-4283-ba02-c77408136713?source=cve
- https://plugins.trac.wordpress.org/browser/easy-pricing-tables/trunk/includes/ept-block.php#L304
- https://plugins.trac.wordpress.org/browser/easy-pricing-tables/trunk/includes/notices/notices.php#L91
More fatcatapps vulnerabilities
- TI-2023-04688 Campaign Monitor Forms < 2.5.6 - Subscriber+ Arbitrary Options Update CVSS 3.1HIGH 8.1
- TI-2022-04254 Pricing Tables WordPress Plugin – Easy Pricing Tables < 3.2.3 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2021-07202 Pixel Cat Lite < 2.6.2 - CSRF to Stored Cross-Site Scripting CVSS 3.1CRITICAL 9.0
- TI-2026-63330 WordPress Easy Pricing Tables plugin <= 4.1.2 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
- TI-2026-63302 WordPress Quiz Cat plugin <= 3.1.1 - SQL Injection vulnerability CVSS 3.1HIGH 7.6
- TI-2025-19863 WordPress Landing Page Cat plugin <= 1.7.8 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2024-8871 · CVE Program
- CVE-2024-8871 · NVD
- FIRST EPSS
- GHSA-r5f9-2fp7-f77w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences