Denial of Service (DoS) in berriai/litellm
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
A Denial of Service (DoS) vulnerability exists in berriai/litellm version v1.44.5. This vulnerability can be exploited by appending characters, such as dashes (-), to the end of a multipart boundary in an HTTP request. The server continuously processes each character, leading to excessive resource consumption and rendering the service unavailable. The issue is unauthenticated and does not require any user interaction, impacting all users of the service.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| BerriAI | berriai/litellm | before v1.65.4-stable | v1.65.4-stable | Patch available | CNA |
| — | litellm (PyPI) | before 1.56.2 | 1.56.2 | Patch available | GHSA-fh2c-86xm-pm2x |
- berriai/litellm VendorBerriAI Affected before v1.65.4-stable Fixed in v1.65.4-stable Patch available CNA
- litellm (PyPI) Vendor— Affected before 1.56.2 Fixed in 1.56.2 Patch available GHSA-fh2c-86xm-pm2x
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:litellm:litellm:*:*:*:*:*:*:*:* | before 1.65.4 | Vulnerable | BerriAI |
| cpe:2.3:a:litellm:litellm:1.65.4:dev2:*:*:*:*:*:* | 1.65.4 dev2 | Vulnerable | BerriAI |
| cpe:2.3:a:litellm:litellm:1.65.4:dev6:*:*:*:*:*:* | 1.65.4 dev6 | Vulnerable | BerriAI |
| cpe:2.3:a:litellm:litellm:1.65.4:dev8:*:*:*:*:*:* | 1.65.4 dev8 | Vulnerable | BerriAI |
| cpe:2.3:a:litellm:litellm:1.65.4:nightly:*:*:*:*:*:* | 1.65.4 nightly | Vulnerable | BerriAI |
- cpe:2.3:a:litellm:litellm:*:*:*:*:*:*:*:* Versions before 1.65.4 Vulnerable ·BerriAI
- cpe:2.3:a:litellm:litellm:1.65.4:dev2:*:*:*:*:*:* Versions 1.65.4 dev2 Vulnerable ·BerriAI
- cpe:2.3:a:litellm:litellm:1.65.4:dev6:*:*:*:*:*:* Versions 1.65.4 dev6 Vulnerable ·BerriAI
- cpe:2.3:a:litellm:litellm:1.65.4:dev8:*:*:*:*:*:* Versions 1.65.4 dev8 Vulnerable ·BerriAI
- cpe:2.3:a:litellm:litellm:1.65.4:nightly:*:*:*:*:*:* Versions 1.65.4 nightly Vulnerable ·BerriAI
Remediation
- Fix · CNA berriai/litellm (berriai) Fixed in v1.65.4-stable
- Fix · GHSA-fh2c-86xm-pm2x litellm (PyPI) Fixed in 1.56.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8984
- 2026-10-03 Alias added: GHSA-fh2c-86xm-pm2x
References
Other 4
- https://github.com/berriai/litellm/commit/4f49f836aa844ac9b6bfbeff27e6f6b2b9cf3f61
- https://github.com/BerriAI/litellm/commit/4f49f836aa844ac9b6bfbeff27e6f6b2b9cf3f61
- https://github.com/BerriAI/litellm
- https://github.com/BerriAI/litellm/blob/8c5ff150f6142608ffe968e4e68429f978fda187/litellm/tests/test_spend_logs.py#L242
More BerriAI Litellm vulnerabilities
- TI-2026-26015 Trivy ecosystem supply chain briefly compromised KEVCVSS 4.0CRITICAL 9.4
- TI-2026-30529 LiteLLM: SQL injection in Proxy API key verification KEVCVSS 4.0CRITICAL 9.3
- TI-2026-30582 LiteLLM: Authenticated command execution via MCP stdio test endpoints KEVCVSS 4.0HIGH 8.7
- TI-2026-42639 LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback KEVCVSS 4.0HIGH 8.8
- TI-2024-05340 Remote Code Execution in BerriAI/litellm CVSS 3.1CRITICAL 9.8
- TI-2024-02760 Server-Side Template Injection in BerriAI/litellm CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-8984 · CVE Program
- CVE-2024-8984 · NVD
- FIRST EPSS
- GHSA-fh2c-86xm-pm2x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences