OAuth2 client id and secret exposed through the web browser in pgAdmin 4
Priority MEDIUM 55CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
pgAdmin versions 8.11 and earlier are vulnerable to a security flaw in OAuth2 authentication. This vulnerability allows an attacker to potentially obtain the client ID and secret, leading to unauthorized access to user data.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.09685 95th percentileScored 2026-11-07
Fix Fixed pgAdmin 4 (pgadmin.org): 8.12pgadmin4 (PyPI): 8.12
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pgadmin.org | pgAdmin 4 | before 8.12 | 8.12 | Patch available | CNA |
| — | pgadmin4 (PyPI) | before 8.12 | 8.12 | Patch available | GHSA-jm9x-rx9x-wpqj |
- pgAdmin 4 Vendorpgadmin.org Affected before 8.12 Fixed in 8.12 Patch available CNA
- pgadmin4 (PyPI) Vendor— Affected before 8.12 Fixed in 8.12 Patch available GHSA-jm9x-rx9x-wpqj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* | before 8.12 | Vulnerable | pgadmin.org |
- cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* Versions before 8.12 Vulnerable ·pgadmin.org
Remediation
- Fix · CNA pgAdmin 4 (pgadmin.org) Fixed in 8.12
- Fix · GHSA-jm9x-rx9x-wpqj pgadmin4 (PyPI) Fixed in 8.12 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9014
- 2026-10-03 Alias added: GHSA-jm9x-rx9x-wpqj
References
More pgadmin.org Pgadmin 4 vulnerabilities
- TI-2024-01901 Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4 CVSS 3.1CRITICAL 9.9
- TI-2024-02918 Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4 CVSS 3.1CRITICAL 9.8
- TI-2022-03867 Code injection in pgadmin4 CVSS 3.1HIGH 8.8
- TI-2026-06875 pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode CVSS 4.0CRITICAL 9.4
- TI-2025-02572 pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment CVSS 3.1CRITICAL 9.9
- TI-2023-00228 Path traversal in pgadmin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-9014 · CVE Program
- CVE-2024-9014 · NVD
- FIRST EPSS
- GHSA-jm9x-rx9x-wpqj · GitHub Advisory Database · CC BY 4.0
- CVE-2024-9014 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences