Contact Form Plugin by Fluent Forms < 5.2.1 - Admin+ Stored XSS
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Fluent Forms WordPress plugin before 5.2.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00367 30th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Fluent Forms (Unknown): 5.2.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Fluent Forms | before 5.2.1 | 5.2.1 | Patch available | CNA |
- Fluent Forms VendorUnknown Affected before 5.2.1 Fixed in 5.2.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fluentforms:contact_form:*:*:*:*:*:wordpress:*:* | before 5.2.1 | Vulnerable | Fluentforms |
- cpe:2.3:a:fluentforms:contact_form:*:*:*:*:*:wordpress:*:* Versions before 5.2.1 Vulnerable ·Fluentforms
Remediation
- Fix · CNA Fluent Forms (Unknown) Fixed in 5.2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9651
- 2026-10-03 Alias added: GHSA-2v3j-xqf9-rv5m
References
More Fluentforms Contact Form vulnerabilities
- TI-2022-03198 FluentForm < 4.3.13 - CSV Injection CVSS 3.1CRITICAL 9.8
- TI-2021-13634 CSRF in WP Fluent Forms < 3.6.67 allows stored XSS and Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2023-00517 FluentForms < 4.3.25 - Contributor+ Stored XSS via Custom HTML Form Field CVSS 3.1MEDIUM 5.4
- TI-2024-02582 Missing authorization in techjewel Fluent Forms – Customizable Contact Forms, Survey… CVSS 3.1CRITICAL 9.8
- TI-2023-10032 WordPress FluentForm Plugin <= 4.3.25 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2024-03867 Deserialization of untrusted data in techjewel Fluent Forms – Customizable Contact Forms… CVSS 3.1HIGH 8.8
Sources
- CVE-2024-9651 · CVE Program
- CVE-2024-9651 · NVD
- FIRST EPSS
- GHSA-2v3j-xqf9-rv5m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences