Read the docs
TI-2024-09814 Aliases CVE-2024-10592GHSA-4q5h-c56v-vfvm

Mapster WP Maps <= 1.6.0 - Authenticated (Contributor+) Stored Cross-Site Scripting

Priority LOW 30CWE-80Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-80.

Summary

The Mapster WP Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the popup class parameter in all versions up to, and including, 1.6.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00816 57th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
mapsterMapster WP Mapsup to 1.6.0—No fix listedCNA
  • Mapster WP Maps Vendormapster Affected up to 1.6.0 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-10592
  2. 2026-10-03 Alias added: GHSA-4q5h-c56v-vfvm

References

  • TI-2026-11023 Improper input validation in Mapster WP Maps CVSS 3.1HIGH 8.8
  • TI-2024-08571 Mapster WP Maps <= 1.5.0 - Incorrect Authorization to Authenticated (Contributor+) Arbitrary Options Update CVSS 3.1HIGH 8.8
  • TI-2026-82329 Unauthenticated stored cross-site scripting in Mapster WP Maps CVSS 3.1HIGH 7.2
  • TI-2026-67933 Cross-site scripting in Mapster WP Maps WordPress plugin CVSS 3.1HIGH 7.1
  • TI-2024-14430 WordPress Mapster WP Maps Plugin <= 1.2.38 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2025-08288 Mapster WP Maps <= 1.20.0 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
See all 7 →

Sources