Read the docs
TI-2026-11023 Aliases CVE-2026-12954GHSA-gxqq-92xq-fjh7

Improper input validation in Mapster WP Maps

Priority MEDIUM 41CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

The Mapster WP Maps plugin for WordPress is vulnerable to Arbitrary User Meta Write in all versions up to, and including, 1.23.0 via the `my_profile_update()` function. This is due to the function performing no nonce verification, no capability check, and no allowlist validation on the meta key supplied via the `acf-photo-gallery-groups` POST parameter before passing both the meta key and its corresponding value directly to `update_user_meta()`. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update arbitrary user meta values, though privilege escalation is not possible.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00648 51st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
mapsterMapster WP Mapsup to 1.23.0—No fix listedCNA
  • Mapster WP Maps Vendormapster Affected up to 1.23.0 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-12954
  2. 2026-10-03 Alias added: GHSA-gxqq-92xq-fjh7
  3. 2026-10-25 EPSS moved to the 50th–90th percentile

References

  • TI-2024-08571 Mapster WP Maps <= 1.5.0 - Incorrect Authorization to Authenticated (Contributor+) Arbitrary Options Update CVSS 3.1HIGH 8.8
  • TI-2026-82329 Unauthenticated stored cross-site scripting in Mapster WP Maps CVSS 3.1HIGH 7.2
  • TI-2026-67933 Cross-site scripting in Mapster WP Maps WordPress plugin CVSS 3.1HIGH 7.1
  • TI-2024-09814 Mapster WP Maps <= 1.6.0 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
  • TI-2024-14430 WordPress Mapster WP Maps Plugin <= 1.2.38 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2025-08288 Mapster WP Maps <= 1.20.0 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
See all 7 →

Sources