Unauthenticated stored cross-site scripting in Mapster WP Maps
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Mapster WP Maps plugin for WordPress is affected up to and including 2.0.5. Its REST route for saving map settings has no permission check, and the stored loading background color is written into a page's inline style without escaping (CWE-79). An unauthenticated remote attacker can store script in pages that runs when a user opens an affected page.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
The Mapster WP Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.0.5. This is due to the /wp-json/mapster-wp-maps/save-mapmaker REST route being registered with a permission_callback that unconditionally returns true (no capability check, no nonce), together with the mapster_write_config_to_acf() helper only sanitizing string config values with sanitize_text_field() — which strips HTML tags but leaves quote characters intact — and the mapster_wp_map shortcode renderer in mapster_wordpress_maps_shortcode_display() concatenating the stored loading_background_color value into a single-quoted inline style attribute without esc_attr(). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
The sources list no fixed version for Mapster WP Maps.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Timeline
- 2026-10-29 Threatist record created from CVE-2026-107743
- 2026-10-29 CISA SSVC decision points changed
- 2026-10-29 Priority changed: MEDIUM → LOW
- 2026-10-29 Alias added: GHSA-4r6v-cgvq-4mgw
References
Other 6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/de1c951f-8b01-44cf-b192-412de9fae4fa?source=cve
- https://plugins.trac.wordpress.org/browser/mapster-wp-maps/tags/2.0.5/public/class-mapster-wordpress-maps-public.php#L262
- https://plugins.trac.wordpress.org/browser/mapster-wp-maps/tags/2.0.5/admin/api/config-converter.php#L523
- https://plugins.trac.wordpress.org/browser/mapster-wp-maps/tags/2.0.5/admin/api/class-mapster-wordpress-maps-api.php#L487
- https://plugins.trac.wordpress.org/browser/mapster-wp-maps/tags/2.0.5/admin/api/field-map.php#L304
- https://plugins.trac.wordpress.org/browser/mapster-wp-maps/tags/2.0.6/public/class-mapster-wordpress-maps-public.php
More mapster vulnerabilities
- TI-2026-11023 Improper input validation in Mapster WP Maps CVSS 3.1HIGH 8.8
- TI-2024-08571 Mapster WP Maps <= 1.5.0 - Incorrect Authorization to Authenticated (Contributor+) Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2026-67933 Cross-site scripting in Mapster WP Maps WordPress plugin CVSS 3.1HIGH 7.1
- TI-2024-09814 Mapster WP Maps <= 1.6.0 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
- TI-2024-14430 WordPress Mapster WP Maps Plugin <= 1.2.38 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2025-08288 Mapster WP Maps <= 1.20.0 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
Sources
- CVE-2026-107743 · CVE Program
- CVE-2026-107743 · NVD
- FIRST EPSS
- GHSA-4r6v-cgvq-4mgw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences