Cross-site scripting in Mapster WP Maps WordPress plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Mapster WP Maps, a WordPress plugin, is affected through 2.0.4. Improper neutralization of input during web page generation (CWE-79) lets attacker-supplied script be included in pages. An unauthenticated remote attacker can run script in a victim's browser when the victim interacts with a crafted page.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Unauthenticated Cross Site Scripting (XSS) in Mapster WP Maps <= 2.0.4 versions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
The sources list no fixed version for Mapster WP Maps.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Timeline
- 2026-10-06 Threatist record created from CVE-2026-39720
- 2026-10-06 Alias added: GHSA-3c23-3582-jh63
- 2026-10-06 CISA SSVC decision points changed
- 2026-10-06 Priority changed: MEDIUM → LOW
More mapster vulnerabilities
- TI-2026-11023 Improper input validation in Mapster WP Maps CVSS 3.1HIGH 8.8
- TI-2024-08571 Mapster WP Maps <= 1.5.0 - Incorrect Authorization to Authenticated (Contributor+) Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2026-82329 Unauthenticated stored cross-site scripting in Mapster WP Maps CVSS 3.1HIGH 7.2
- TI-2024-09814 Mapster WP Maps <= 1.6.0 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
- TI-2024-14430 WordPress Mapster WP Maps Plugin <= 1.2.38 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2025-08288 Mapster WP Maps <= 1.20.0 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
Sources
- CVE-2026-39720 · CVE Program
- CVE-2026-39720 · NVD
- FIRST EPSS
- GHSA-3c23-3582-jh63 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences